Flight controller wont connect to betaflight and not recognised by my pc

There is a link to the stm32 driver on the front page of the betaflight configurator towards the bottom left hand corner

no it doesnt get hot, it shows a solid red led

I think that only works for windows 7 and 8 I have windows 10. Nevertheless ill try it again.

Have you tried the impluseRC diver fixer? I find this tool to be the easiest to fix any driver issues on windows.

I had a similar issue on my windows 10 laptop…

I’ll try and do a rough guide on how I fixed it tonight when I get to my computer.

OK thanks that would be great

This is a very rough video.
Watch it till the end its only 3:40m then ask any questions.

This is me downloading and installing the ST32 drivers.
@2:48 I plug in my quad
@2:52 I reinstall the drivers, useful if it doesn’t work or stops working.
You may find at this point the drivers have installed and work correctly and you can skip this bit.

i cant seem to find the video

It kind of helps… if i … link the video.

ok, I followed the steps in your video except when installing the stm driver it didn’t ask me which users to install the driver for which was @1:43 in your video and it didnt ask me if i wanted to receive the latest updates(i dont know if it makes a difference)

But, when i did try to install the stm, it asked me if i wanted to modify, replace, or delete(i clicked modify) Also when I try to install it goes up to “preparing to install” @1:15

Also i cannot find the stmelectronincs file (at the end of your video) to updates the driver and dont have a st virtual driver under my ports (com)

Overall it didnt work

That’s a feature of my machine. you did the right thing just to carry on.

Modify is fine… replace may have been bettee

The com port only shows when you FC is plugged into your computer

Below is the file path the drivers
C:\Program Files (x86)\STMicroelectronics\Software\Virtual comport driver\Win7

I used your file path to download the driver but still had no luck

Ok the last option I can think of.

Is trying to remotely install the drivers for you and connect to betaflight.

ok lets do that then.

It would be fine to do it tommorow if its too late now.

I have a similar problem. I have 3 drones - a Wizard, trashcan, and mantis. None of them even register when I plug them into a USB port. I don’t get the audible chime when you plug something in. I’ve tried many of the steps above without success. A virtual COM port does not show up in the Windows device manager, or in either of the utilities above. Is there a way to clear them out and start over? Everything was working until yesterday. Thanks for the help

Try a different USB Cable…
Some USB cables do power only and not data.

I find it strange with 3 different none of them connect,

1 Like

Delete the driver and restart pc , also make sure your using a data cable and not a charging cable

1 Like

I made an Account just to say thank you so much. I probably would have never figured out that it’s the cable that’s the issue. Because i even tried a different micro… too bad that one was also a charging cable lol.

1 Like

Hello,
1st of all I’m a beginner to FPV.
I have racestar f4s and when it’s plugged via usb it’s not recognized by my laptop and the FC gets hot ,and all leds are Off, and my usb cable works fine , everything was working yesterday .